Portal & API: outage due to Microsoft Azure outage

Incident Report for Kyckr

Resolved

While the Azure outage appears to be resolved, the Kyckr team are continuing to monitor the situation.
Posted Oct 29, 2025 - 20:45 UTC

Identified

Microsoft provided an update via their status page at 17:18 UTC. The issue is confirmed to be with Azure network availability, affecting all regions. Microsoft is rolling back to the last known good state.

We will continue to provide updates as we receive them. Microsoft have not provided an ETA for the rollback.

Further information can be found on the Azure status page: https://azure.status.microsoft/en-us/status and in a dedicated X thread, started by Microsoft: https://x.com/MSFT365Status/status/1983571232122671591
Posted Oct 29, 2025 - 17:36 UTC

Investigating

We are investigating an outage on the Kyckr Portal and API. The issue is related to a global Microsoft Azure (cloud services) outage, which is visible on the Microsoft status page and being reported across Downdetector and other news sites.

https://azure.status.microsoft/en-us/status

We apologise for any inconvenience. Further updates will be provided in line with updates from Microsoft.
Posted Oct 29, 2025 - 16:34 UTC
This incident affected: API and Kyckr Portal.