United Kingdom: Enhanced Profiles Unavailable

Incident Report for Kyckr

Resolved

We can confirm that the issue affecting the processing of our Enhanced Profiles product for the United Kingdom has been resolved. All services are now operating normally. We apologise for any inconvenience caused.
Posted Mar 31, 2026 - 13:11 UTC

Identified

We have identified an issue affecting our Enhanced Profiles product for the United Kingdom. Our technical team is currently working on a fix and we will provide an update shortly
Posted Mar 31, 2026 - 13:05 UTC
This incident affected: United Kingdom (Core).