Netherlands: Degraded service at registry

Incident Report for Kyckr

Resolved

The registry have resolved the issue and trade registry history documents are available. Thank you for your patience.
Posted Sep 11, 2025 - 15:11 UTC

Monitoring

The Netherlands registry is currently experiencing an issue affecting only trade registry history documents and are working on a solution
Posted Sep 09, 2025 - 12:53 UTC
This incident affected: Netherlands (Documents).