Unable to access documents from Guernsey registry

Incident Report for Kyckr

Resolved

This incident has been resolved.
Posted Mar 30, 2026 - 14:55 UTC

Identified

There is an issue at the Guernsey registry preventing us from accessing documents
Posted Mar 30, 2026 - 11:17 UTC
This incident affected: Guernsey (Documents).