Delay in processing German document orders

Incident Report for Kyckr

Resolved

This incident has been resolved.
Posted Feb 16, 2026 - 14:59 UTC

Identified

We are aware of a technical issue at the German registry that is preventing us from completing document orders. These orders will be completed as soon as the issue at the registry is resolved
Posted Feb 04, 2026 - 12:37 UTC
This incident affected: Germany (Documents).