Sweden Registry Unavailable
Incident Report for Kyckr
Resolved
This incident has been resolved.
Posted Apr 12, 2024 - 10:03 UTC
Investigating
We are currently investigating an issue with the Swedish Registry. Customers may experience issues when ordering profiles and documents for Sweden during this time.
Posted Mar 13, 2024 - 11:34 UTC
This incident affected: Sweden (Core, Lite, Documents).