Issue connecting to Brazil Registry

Incident Report for Kyckr

Resolved

This incident has been resolved.
Posted Mar 25, 2026 - 16:09 UTC

Investigating

We are currently investigating an issue with connecting to the Brazilian registry.
Posted Mar 25, 2026 - 10:29 UTC
This incident affected: Brazil (Documents, Core, Lite).