Cayman Islands Search Unavailable

Incident Report for Kyckr

Resolved

The Cayman Islands registry is now functioning as normal again. We are continuing to monitor the issue and will provide further updates in the event of continued degraded performance.
Posted Apr 23, 2025 - 13:09 UTC

Investigating

We are investigating an issue with Cayman Islands company search, across both the Kyckr API and Portal. Performance may be intermittent.
Posted Apr 22, 2025 - 10:48 UTC
This incident affected: Cayman Islands (Core, Documents).