South Africa Registry Unavailable
Incident Report for Kyckr
Resolved
This incident has been resolved.
Posted Apr 19, 2024 - 11:14 UTC
Investigating
The South African registry is currently experiencing technical issues at the source. Customers may experience issues when ordering documents and profiles for South Africa during this time.
Posted Mar 20, 2024 - 12:14 UTC
This incident affected: South Africa (Documents, Lite, Core).