French registry unavailable

Incident Report for Kyckr

Resolved

This incident has been resolved.
Posted Aug 03, 2026 - 07:31 UTC

Investigating

We are aware of an issue impacting orders to France. Our technical team is investigating the cause.
Posted Aug 03, 2026 - 03:20 UTC
This incident affected: France (Lite, Documents, Core).