Intermittent connectivity issues with Estonian registry

Incident Report for Kyckr

Resolved

This incident has been resolved.
Posted Mar 30, 2026 - 11:16 UTC

Investigating

We are investigating an intermittent issue with connecting to the Estonian registry
Posted Mar 25, 2026 - 16:48 UTC
This incident affected: Estonia (Lite, Core, Documents).