Unable to do ABN searches in Australia

Incident Report for Kyckr

Resolved

This incident has been resolved.
Posted Feb 13, 2026 - 03:25 UTC

Investigating

We are currently investigating this issue where ABN searches e.g. for sole traders is not responding. ACN searches for companies is not impacted.
Posted Feb 13, 2026 - 00:09 UTC
This incident affected: Australia (Lite).