France - Extended Company profile

Incident Report for Kyckr

Resolved

This incident has been resolved.
Posted Mar 02, 2026 - 08:38 UTC

Identified

We are aware of an issue with the French Document - Extended Company Profile. Currently orders placed for this documents are failing to complete. We are investigating the issue with the registry
Posted Feb 25, 2026 - 13:46 UTC
This incident affected: France (Documents).