Italian Registry

Incident Report for Kyckr

Resolved

This incident has been resolved.
Posted Feb 25, 2026 - 15:22 UTC

Identified

We are currently unable to connect to the Italian registry due to disruptions to the registry's service.
Posted Feb 25, 2026 - 10:35 UTC
This incident affected: Italy (Core, Lite, Documents).