Issues with structured data retrieval: Ireland, Belgium, Netherlands and Germany

Incident Report for Kyckr

Resolved

This incident has been resolved.
Posted Sep 01, 2026 - 08:26 UTC

Investigating

We are investigating an issue affecting data retrieval in four European jurisdictions: Ireland, Belgium, Netherlands and Germany.

Enhanced profiles and Ownership Discovery may experience intermittent issues during this time.

We apologise for any disruption. Further updates will be provided in due course.
Posted Aug 31, 2026 - 17:08 UTC
This incident affected: Germany (Core), Ireland (Core), Netherlands (Core), and Belgium (Core).