Netherlands Uittreksel and History currently unavailable
Incident Report for Kyckr
Resolved
This incident has been resolved.
Posted Apr 26, 2024 - 10:51 UTC
Monitoring
The Uittreksel (in Dutch) and History documents are currently unavailable at the Netherlands Registry due to issues on the registry's side. All other documents are still available, as well as Enhanced and Lite profiles. We are in contact with the registry and are monitoring this situation awaiting a resolution.
Posted Apr 19, 2024 - 11:12 UTC
This incident affected: Netherlands (Documents).