Malta Business Registry currently unavailable

Incident Report for Kyckr

Resolved

The issue at the registry has been resolved
Posted Dec 10, 2025 - 09:11 UTC

Monitoring

The Malta Registry are currently having issues with their site. The Kyckr team are monitoring the situation.
Posted Dec 09, 2025 - 11:22 UTC
This incident affected: Malta (Core, Documents, Lite).