Degraded Performance Romanian Registry- Filing Documents

Incident Report for Kyckr

Resolved

This incident has been resolved and the registry is now delivering documents within expected time frames.
Posted Jun 24, 2025 - 14:50 UTC

Monitoring

The Romanian registry is experiencing delays in returning filing documents. We are monitoring the situation and fulfilling orders as soon as documents are returned.
Posted Jun 24, 2025 - 11:40 UTC
This incident affected: Romania (Documents).